Linux Kernel 3.8.* – VMware failed to build vmci · uwot.eu
another meaningless subtitle

Linux Kernel 3.8.* – VMware failed to build vmci

· by fabio · Read in about 1 min · (145 Words)
fedora 18 kernel 3.8 vmci vmware workstation 9

Every time a new Kernel goes out there seems to be a new issue with VMware Workstation 9.
Today I updated a couple of Fedora 18 boxes, applied the usual workaround (I wrote a post about it one month ago or so) which consists in ONE OF the following steps:

ln -s /usr/src/kernels/_kernel_version_/include/generated/uapi/linux/version.h /usr/src/kernels/_kernel_version_/include/linux/version.h
### OR
cp /usr/src/kernels/_kernel_version_/include/generated/uapi/linux/version.h /lib/modules/_kernel_version_/build/include/linux/

Rebooted and then issued the usual command (vmware-modconfig –console –install-all) to rebuild the needed VMware modules just to find out that it isn’t possible to rebuild the VMCI module.
On the VMware official forum I found a thread (http://communities.vmware.com/message/2182440#2182440) in which a user provides a patch.
Apply the patch is fairly simple:
1. cd /usr/lib/vmware/modules/source
2. tar -xf vmci.tar
3. cd vmci-only
4. patch -p1 < ‘patchfile’ 5. cd .. 6. tar -cf vmci.tar vmci-only/ 7. vmware-modconfig –console –install-all 8. rm -rf vmci-only/

Download link: linux-3.8_vmci_pci_hotplug_struct.patch